• 0
demonex

Настройки сети в ОС Linux

Вопрос

Рекомендованные сообщения

  • 0

Кто победил сетевые настройки - помогите. Вынужден поставить на нетбук никс-систему(остановился на лубунту 12.04), и третий день мучаюсь - не могу настроить локальную сеть, что не работает - непонятно. Мак вроде прописываю и клонированный и через ifconfig, несть не подключается и непонятно почему.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
  • 0

Кто победил сетевые настройки - помогите. Вынужден поставить на нетбук никс-систему(остановился на лубунту 12.04), и третий день мучаюсь - не могу настроить локальную сеть, что не работает - непонятно. Мак вроде прописываю и клонированный и через ifconfig, несть не подключается и непонятно почему.

Тут много писали о перезапуске dhcp-клиента для получения параметров сетевого интерфейса, но если не знать как dhcp-сервер настроен на стороне провайдера(да и зачем обычному пользователю это знать???), то можно долго ломать голову или не получить никакого результата вовсе...

Самое простое: После того, как настроили сетевой интерфейс (выставили для Проводного соединения Клонированый MAC-адрес в закладке "Проводные", потом Способ настройки: Автоматически (DHCP) в закладке "Параметры IPv4"), попробуйте перезапустить сетевой интерфейс (кликните на значке сети и снимите и снова поставьте галочку на Управление сетью). Таким образом вы перезапустите не только сетевой интерфейс, но и dhcp-клиент, что в большинсве случаев помогает.

Если не помогло, тогда пробуем перезапустить dhcp-клиент след. образом:

как здесь http://www.cyberciti...ent-ip-address/

Если и это не помогло, тогда вручную нужно прописать все параметры сети (но это у провайдера нужно узнать).

Можно проверить, работает ли сеть:

ifconfig -a

и правильно ли запущен dhcp-клиент(подробнее потом напишу):

ps -ef  | grep dhclient

У меня стоит Ubuntu 12.04 на ноуте Fujitsu AH531/GFO. Никаких проблем не было ни с прямым подключением, ни через Wi-Fi-роутер. Просто клонировал MAC-адрес и всё работало без проблем. А пробовали ping запустить во внешний мир, или на шлюз Макснета? Если всё правильно настроено у вас и у провайдера и не работает, тогда тут "проблемы" могут быть только с сетевой картой Вашего нетбука: либо она плохо уживается с сетевыми драйверами linux и тогда нужно подобрать подходящий, либо, что самое худшее - это плохая электрическая совместимость Вашей сетевой карты с коммутатором провайдера (но это очень редкий случай, хотя в моей практике было и такое). Что за нетбук, кстати?

Поэтому сначала лучше обратиться в службу поддержки по телефону и получить консультацию специалистов Макснета вживую, если не помогут, тогда уже бить в бубен на форумах. Лучше всеего здесь http://forum.ubuntu.ru :-)

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
  • 0

Стоит Ubuntu 12.04 на ноуте Fujitsu AH531/GFO. Никаких проблем не было ни с прямым подключением, ни через Wi-Fi-роутер. Просто клонировал MAC-адрес и всё работало без проблем. А пробовали ping запустить во внешний мир, или на шлюз Макснета? Если всё правильно настроено и не работает, тогда тут "проблемы" могут быть только с сетевой картой Вашего нетбука: либо она плохо уживается с сетевыми драйверами linux и тогда нужно подобрать подходящий, либо, что самое худшее - это плохая совместимость Вашей сетевой карты с коммутатором провайдера (но это очень редкий случай, хотя в моей практике было и такое). Что за нетбук, кстати?

P.S. Сначала лучше обратиться в службу поддержки по телефону и получить консультацию специалистов Макснета вживую, если не помогут, тогда уже бить в бубен на форумах. Лучше всеего здесь http://forum.ubuntu.ru :-)

Я буквально вчера стояла Убунта 12.04. Поменял потому что притормаживала и не добился ничего. На Убунте с вайфаем проблем не было, видел все доступные, а вот с локалкой - беда, не хотел ни в какую. Напиши пожалуйста полнее что ты где прописывал в настройке подключения(точнее где какие пункты выбирал, выставлял ИП6 на автоматическую настройку или игнорировать и пр.).

Может быть и с дровами беда, так как под Вин 7 я сеть настраивал нормально, все работало. Я попробую сам, а потом уже звонить, а то обычно, насколько знаю, они таким не занимаются, сеть они провели и она работает, а то что я решил на другую ось перейти так то мои проблемы(

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
  • 0
Что за нетбук, кстати?

Нетбук Lenovo s12. Пробовал все, не получается. Напиши пожалуйста ставишь ли ты галочку на "Требовать адресацию ИПв4" и что там с ИПв6, знаю в Вин 7 её отключать надо было. А тут? Пинг кстати не пройдет, так как подключения нет. При попытке соединиться - пишет "Соединение разорвано". Пробовал уже редактировать dhclient.conf и там прописать МАК, пока безрезультатно....

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
  • 0

Нетбук Lenovo s12. Пробовал все, не получается. Напиши пожалуйста ставишь ли ты галочку на "Требовать адресацию ИПв4" и что там с ИПв6, знаю в Вин 7 её отключать надо было. А тут? Пинг кстати не пройдет, так как подключения нет. При попытке соединиться - пишет "Соединение разорвано". Пробовал уже редактировать dhclient.conf и там прописать МАК, пока безрезультатно....

Не лезь в дебри, ты же не специалист по сетям и протоколам, просто добавь клонированный МАС-адрес в оконном интерфейсе (который зарегестрирован у провайдера) и перезапусти сеть, как я написал. ВСЁ!

Попробовал, подключить свой ноут по проводу по dhcp, и он не подключился, хотя dhclient и получал файл аренды, но почему то соединение не устанавливовалось (((

Если

ps -ef | grep dhclient

выдаёт следующее:

root 2000 801 0 12:39 ? 00:00:00 /sbin/dhclient -d -4 -sf /usr/lib/NetworkManager/nm-dhcp-client.action -pf /var/run/sendsigs.omit.d/network-manager.dhclient-wlan0.pid -lf /var/lib/dhcp/dhclient-XXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX-eth0.lease -cf /var/run/nm-dhclient-eth0.conf eth0

где dhclient-XXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX-eth0.lease - файл аренды IP-адресов, то по идее всё должно работать,

но у меня не работало (((

Причём через свой маршрутизатор ZYXEL Keenetic Lite (и по Wi-Fi, и по проводу) всё нормально. И дело не в Ubunu и его драйверах, просто в идеале нужно знать, как настоен DHCP у Макснета и потом искать возможность под него подстроиться, если конечно они не намерено отрубают "автомат" для Linux (что вряд ли). dhcp - клиент ZyXEL-я проходит же, и он тоже на linux работает :)

Проблему решил установкой IP-адресов вручную:

1. Входим в NetworkManager (т.е. кликаем на значок сети)

2. В выпадающем меню (должна быть установлена галочка на Управление сетью) кликаем Изменить соединение...

3. В открывшемся окне Сетевые соединеня в закладке Проводные выбираем соединение и жмём Изменить...

(или двойной клик на выбранном соединении)

4. В окне Измение Проводное соединение в закладке Проводные вводим клонированный MAC-адрес в соответствующее поле

5. Переходим на закладку Параметры IPv4, выбираем Способ настройки: Вручную, добавляем Адрес, Macку сети, Шлюз, Серверы DNS( через запятую). Их значения можно найти в файле аренды адресов dhcp-клиента в каталоге /var/lib/dhcp:

ls -al /var/lib/dhcp

, если этот файл всё-таки копируется на локальный комп, в противном случае нужно их искать

в сведениях о соединении в Win7 для твоего случая.

Находим самый новый файл аренды IP-адресов dhclient-XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX-eth0.lease, в имени которого должно быть имя проводного сетевого интерфейса (напр., eth0, eth1 и т.д.) или файл dhclient.leases, который хранит резервные копии арендованных ранее IP-адресов для сетвого/вых интерфеса.

Эти файлы должны содержать IP-значения Адрес, Macка сети, Шлюз, Серверы DNS (выделены жирным)для сетевого интерфейса,

которые и нужны. Напр.,

less /var/lib/dhcp/dhclient.leases

lease {

interface "eth0";

fixed-address 178.100.100.100;

option subnet-mask 255.255.252.0;

option dhcp-lease-time 86400;

option routers 178.100.100.1;

option dhcp-message-type 5;

option dhcp-server-identifier 178.100.100.10;

option domain-name-servers 79.100.100.3,79.100.100.1;

option ntp-servers 79.100.100.30,79.100.100.1;

option domain-name "maxnet.ua";

renew 2 2012/01/06 19:35:19;

rebind 3 2012/01/07 05:37:35;

expire 3 2012/01/07 08:37:35;

}

Если информация в этих файлах устарела, можно получить файл аренды, запустив:

sudo dhclient -r

после этого должен обновиться файл dhclient.leases, если блоков lease больше одного, смотрим на последний.

Тут можно сразу запустить:

sudo dhclient

после чего последний блок lease из файла dhclient.leases скопируется во вновь созданный файл

dhclient-XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX-eth0.lease.

и если сеть поднимется (значит соединение установилось автоматически), выйти из NetworkManager-а, если нет, то завершить ввод IP-значений.

6. Снимаем галочку с Требовать адресацию IPv4 для этого соединения, если установлена

7. Жмём Сохранить...

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
  • 0

Не знаю, может кому нибудь поможет, но у меня в Убунту 10.04 заработала сеть с автоматическими настройками только тогда, когда я в НетворкМенеджере на вкладке "Параметры IPv6" в раскрывающемся списке "Профиль:" вместо "Автоматически" выбрал "Игнорировать". А до этого работали только ручные настройки.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
  • 0

Добрый день.

Вот что помогло решить эту проблему:

в терминале sudo gedit /etc/dhcp3/dhclient.conf

в строке # send dhcp-client-identifier 1:XX:XX:XX:XX:XX:XX; убираем # и вместо иксов пишем свой MAC адрес( обязательно перед MACом пишется 1), сохраняем,перезапускаемся и DHCP получает настройки автоматически.

И конечно же в network manager должно стоять Автоматически ( DHCP).

P.S. У меня mint10, поэтому в других дистрах адрес конфига может отличаться, да и текстовый редактор может быть другой ( например pluma), ну я думаю кому надо,тот разберется.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
  • 0

Помогите пожалуйста настроить интернет на Ubuntu 12.10.

Сначала интернета вообще не было, сейчас как-то заработал ipv6, то есть заходит только на сайты с v6.

Прописывал мак-адрес, вручную настраивал ipv4, через терминал менял interfaces, ничего не помогает.

Подскажите пожалуйста что нужно сделать :(

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
  • 0

Помогите пожалуйста настроить интернет на Ubuntu 12.10.

Сначала интернета вообще не было, сейчас как-то заработал ipv6, то есть заходит только на сайты с v6.

Прописывал мак-адрес, вручную настраивал ipv4, через терминал менял interfaces, ничего не помогает.

Подскажите пожалуйста что нужно сделать :(

В терминале выполните команду ifconfig.

Результат выполнения скриншотом или текстом прикрепите здесь.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
  • 0

Народ кто знает подскажите как настроить интернет в ubuntu 13.04?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
  • 0

Доброе время суток,

После апгрейда Linux-a скорость соединения упала в разы :-(

Уверен, что что-то мной не доработано, возможно где-то глючит маршрутизация

(на машине 3 сетевых интерфейса, включая внешний)

Есть на форуме специалисты в этом вопросе

или придется заказывать помощь из техподдержки?

Чтобы было понятно - в чем вообще дело, описано ниже.

-------------------------------------

Есть машина, установлен Linux (CentOS 6.4)

поскольку иногда требуется Windows, установлен пакет VMware

** интерфейсы:

eth0 - смотрит "наружу", на maxnet gateway: 178.165.68.1

vmnet1 - виртуальный интерфейс для связи с VMware (гость WinXP-SP3)

        подсеть 192.168.1.0/24

eth1 - сетевая карта на случай подключения ноутбука

        подсеть 192.168.0.0/24

** В чем суть проблемы:

1. Если Maxnet-кабель напрямую подлючить к ноутбуку (мимо Linux-машины)

всё работает нормально, т.е. скорость в порядке!

2. Если Maxnet-кабель подключен к eth0 на Linux-машине,

сеть тормозит, скорость падает где-то в 5 раз (20 кб/сек вместо 100-120 кб/сек)

Причем тормоза везде, независимо от точки потребления:

или напряму из линукса, или через VMware-гостя,

или через подключенный ноутбук.

---------------------------------- Linux:

Kernel IP routing table

Destination     Gateway         Genmask         Flags   MSS Window  irtt Iface

192.168.1.0     0.0.0.0         255.255.255.0   U         0 0          0 vmnet1

192.168.0.0     0.0.0.0         255.255.255.0   U         0 0          0 eth1

178.165.68.0    0.0.0.0         255.255.254.0   U         0 0          0 eth0

0.0.0.0         178.165.68.1    0.0.0.0         UG        0 0          0 eth0

----- ifconfig:

eth0      Link encap:Ethernet  HWaddr 00:11:3B:0A:6F:50  

          inet addr:178.165.XX.XX  Bcast:178.165.71.255  Mask:255.255.252.0

          inet6 addr: fe80::211:3bff:fe0a:6f50/64 Scope:Link

          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1

          RX packets:5849386 errors:64810 dropped:142004 overruns:36030 frame:0

          TX packets:2998482 errors:0 dropped:0 overruns:0 carrier:0

          collisions:388410 txqueuelen:1000

          RX bytes:2762794270 (2.5 GiB)  TX bytes:221192825 (210.9 MiB)

          Interrupt:11 Base address:0x8c00

eth1      Link encap:Ethernet  HWaddr 50:46:5D:B8:65:D2  

          inet addr:192.168.0.5  Bcast:192.168.0.255  Mask:255.255.255.0

          UP BROADCAST MULTICAST  MTU:1500  Metric:1

          RX packets:0 errors:0 dropped:0 overruns:0 frame:0

          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0

          collisions:0 txqueuelen:1000

          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

          Interrupt:10

lo        Link encap:Local Loopback  

          inet addr:127.0.0.1  Mask:255.0.0.0

          inet6 addr: ::1/128 Scope:Host

          UP LOOPBACK RUNNING  MTU:16436  Metric:1

          RX packets:13781 errors:0 dropped:0 overruns:0 frame:0

          TX packets:13781 errors:0 dropped:0 overruns:0 carrier:0

          collisions:0 txqueuelen:0

          RX bytes:1414609 (1.3 MiB)  TX bytes:1414609 (1.3 MiB)

vmnet1    Link encap:Ethernet  HWaddr 00:50:56:C0:00:01  

          inet addr:192.168.1.2  Bcast:192.168.1.255  Mask:255.255.255.0

          inet6 addr: fe80::250:56ff:fec0:1/64 Scope:Link

          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1

          RX packets:1206480 errors:0 dropped:0 overruns:0 frame:0

          TX packets:5745234 errors:0 dropped:0 overruns:0 carrier:0

          collisions:0 txqueuelen:1000

          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

-------------------------

Кроме этого, включен проброс IP4-пакетов и IP-маскарадинг в iptables

для двух подсетей:

iptables -A FORWARD -s 192.168.0.0/24 -j ACCEPT

iptables -A FORWARD -d 192.168.0.0/24 ACCEPT

iptables -t nat -A POSTROUTING -o eth0 -s 192.168.0.0/24 -j MASQUERADE

iptables -A FORWARD -s 192.168.1.0/24 -j ACCEPT

iptables -A FORWARD -d 192.168.1.0/24 -j ACCEPT

iptables -t nat -A POSTROUTING -o eth0 -s 192.168.1.0/24 -j MASQUERADE

----------------------------------

ping из линуха:

PING ya.ru (213.180.204.3) 56(84) bytes of data.

64 bytes from www.yandex.ru (213.180.204.3): icmp_seq=1 ttl=58 time=40.2 ms

64 bytes from www.yandex.ru (213.180.204.3): icmp_seq=2 ttl=58 time=998 ms

64 bytes from www.yandex.ru (213.180.204.3): icmp_seq=3 ttl=59 time=971 ms

64 bytes from www.yandex.ru (213.180.204.3): icmp_seq=5 ttl=59 time=973 ms

64 bytes from www.yandex.ru (213.180.204.3): icmp_seq=6 ttl=58 time=64.7 ms

64 bytes from www.yandex.ru (213.180.204.3): icmp_seq=7 ttl=59 time=275 ms

--- ya.ru ping statistics ---

8 packets transmitted, 6 received, 25% packet loss, time 7127ms

rtt min/avg/max/mdev = 40.266/553.979/998.385/433.700 ms

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
  • 0

Доброе время суток,

После апгрейда Linux-a скорость соединения упала в разы :-(

Уверен, что что-то мной не доработано, возможно где-то глючит маршрутизация

Быть может проблема в сетевой карте ?

в другую воткнуть и замерять не пробовал ? (раз на ноуте супер, а комп - беда)

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
  • 0

Подкреплю выше пост RobertoCarlos скринами настройки сети в Ubuntu (Unity). Обязательно в строке ID клиента DHCP перед MAC адресом поставить 1: (один и двоеточие)

Ставим клон MAC адреса.

post-24381-0-60565300-1405770684_thumb.png

Меняем ID клиента DHCP.

post-24381-0-81591500-1405770690_thumb.png

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Присоединяйтесь к обсуждению

Вы можете опубликовать сообщение сейчас, а зарегистрироваться позже. Если у вас есть аккаунт, войдите в него для написания от своего имени.

Гость
Ответить на вопрос...

×   Вставлено в виде отформатированного текста.   Вставить в виде обычного текста

  Разрешено не более 75 эмодзи.

×   Ваша ссылка была автоматически встроена.   Отобразить как ссылку

×   Ваш предыдущий контент был восстановлен.   Очистить редактор

×   Вы не можете вставить изображения напрямую. Загрузите или вставьте изображения по ссылке.

Загрузка...